Kamis, 18 Maret 2021

Bagaimana cara Install Discord di Linux Ubuntu 20.04 LTS?

 

Konsep Discord berasal dari Jason Citron, yang telah mendirikan OpenFeint, platform permainan sosial untuk permainan seluler. Dia menjual OpenFeint ke GREE pada 2011 seharga US$104 juta, yang ia gunakan untuk mendirikan Hammer & Chisel, sebuah studio pengembangan permainan, pada tahun 2012. Produk pertama mereka adalah Fates Forever, dirilis pada tahun 2014, yang diharapkan Citron sebagai permainan MOBA pertama di platform seluler, tetapi tidak sukses secara komersial.

Discord dirilis secara publik pada Mei 2015 dengan nama domain discordapp.com. Menurut Citron, mereka tidak melakukan langkah khusus untuk menargetkan audiens tertentu, tetapi subreddits mengganti tautan IRC mereka dengan tautan Discord. Discord menjadi banyak digunakan oleh para gamer esports dan turnamen LAN. Perusahaan mendapat manfaat dari hubungan dengan streammer Twitch dan komunitas subreddit untuk Diablo dan World of Warcraft.

Mulai Juni 2020, Discord mengumumkan pengalihan fokus dari kekhususan permainan video ke komunikasi yang lebih serbaguna dan klien obrolan untuk semua fungsi, mengungkapkan slogan barunya "Your place to talk" dan situs web yang direvisi. Di antara perubahan yang direncanakan lainnya adalah mengurangi jumlah lelucon permainan yang digunakannya dalam klien, meningkatkan pengalaman orientasi pengguna, dan meningkatkan kapasitas dan keandalan server. Perusahaan mengumumkan telah menerima tambahan investasi sebesar US$100 juta untuk membantu perubahan ini.

Discord adalah aplikasi voice chat gratis yang bisa dipakai untuk berkomunikasi. Biasanya aplikasi ini digunakan oleh para pemain game online. Belakangan, aplikasi yang dirilis pada 2015 lalu ini kembali naik daun. Discord sendiri tersedia untuk perangkat Windows, Linux, Mac, Android, dan iOS

Untuk download aplikasi discord untuk linux ubuntu 20.04 LTS bisa didapatkan disini :
https://discordapp.com/api/download?platform=linux&format=deb

Cara installnya :

1. Install paket deb nya dulu :

$ sudo dpkg -i discord-0.0.13.deb 
[sudo] password for dony: 
Selecting previously unselected package discord.
(Reading database ... 296714 files and directories currently installed.)
Preparing to unpack discord-0.0.13.deb ...
Unpacking discord (0.0.13) ...
dpkg: dependency problems prevent configuration of discord:
 discord depends on libappindicator1; however:
  Package libappindicator1 is not installed.
 discord depends on libc++1; however:
  Package libc++1 is not installed.
dpkg: error processing package discord (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Errors were encountered while processing:
 discord
 
2. Kalau muncul error, berarti masih ada paket tambahan yang dibutuhkan, tinggal install saja dengan perintah ini :
 
$ sudo apt install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libappindicator1 libc++1 libc++1-10 libc++abi1-10 libdbusmenu-gtk4
Suggested packages:
  indicator-application clang
The following NEW packages will be installed:
  libappindicator1 libc++1 libc++1-10 libc++abi1-10 libdbusmenu-gtk4
0 upgraded, 5 newly installed, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
Need to get 306 kB of archives.
After this operation, 1.360 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://id.archive.ubuntu.com/ubuntu focal/universe amd64 libdbusmenu-gtk4 amd64 16.04.1+18.10.20180917-0ubuntu6 [27,5 kB]
Get:2 http://id.archive.ubuntu.com/ubuntu focal/universe amd64 libappindicator1 amd64 12.10.1+20.04.20200408.1-0ubuntu1 [22,8 kB]
Get:3 http://id.archive.ubuntu.com/ubuntu focal/universe amd64 libc++abi1-10 amd64 1:10.0.0-4ubuntu1 [59,4 kB]
Get:4 http://id.archive.ubuntu.com/ubuntu focal/universe amd64 libc++1-10 amd64 1:10.0.0-4ubuntu1 [193 kB]
Get:5 http://id.archive.ubuntu.com/ubuntu focal/universe amd64 libc++1 amd64 1:10.0-50~exp1 [2.904 B]
Fetched 306 kB in 3s (117 kB/s)
Selecting previously unselected package libdbusmenu-gtk4:amd64.
(Reading database ... 296799 files and directories currently installed.)
Preparing to unpack .../libdbusmenu-gtk4_16.04.1+18.10.20180917-0ubuntu6_amd64.deb ...
Unpacking libdbusmenu-gtk4:amd64 (16.04.1+18.10.20180917-0ubuntu6) ...
Selecting previously unselected package libappindicator1.
Preparing to unpack .../libappindicator1_12.10.1+20.04.20200408.1-0ubuntu1_amd64.deb ...
Unpacking libappindicator1 (12.10.1+20.04.20200408.1-0ubuntu1) ...
Selecting previously unselected package libc++abi1-10:amd64.
Preparing to unpack .../libc++abi1-10_1%3a10.0.0-4ubuntu1_amd64.deb ...
Unpacking libc++abi1-10:amd64 (1:10.0.0-4ubuntu1) ...
Selecting previously unselected package libc++1-10:amd64.
Preparing to unpack .../libc++1-10_1%3a10.0.0-4ubuntu1_amd64.deb ...
Unpacking libc++1-10:amd64 (1:10.0.0-4ubuntu1) ...
Selecting previously unselected package libc++1:amd64.
Preparing to unpack .../libc++1_1%3a10.0-50~exp1_amd64.deb ...
Unpacking libc++1:amd64 (1:10.0-50~exp1) ...
Setting up libc++abi1-10:amd64 (1:10.0.0-4ubuntu1) ...
Setting up libdbusmenu-gtk4:amd64 (16.04.1+18.10.20180917-0ubuntu6) ...
Setting up libc++1-10:amd64 (1:10.0.0-4ubuntu1) ...
Setting up libappindicator1 (12.10.1+20.04.20200408.1-0ubuntu1) ...
Setting up libc++1:amd64 (1:10.0-50~exp1) ...
Setting up discord (0.0.13) ...
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...
$

3. Kalau sudah tinggal jalankan saja dari menu apalikasi nya, pertama kali aplikasi ini akan minta update terlebih dahulu, dan pastikan terkoneksi ke Internet dan biarkan update sampai selesai :



Setelah selesai tinggal login dengan cara scan barcode dari aplikasi yang ada di handphone android, dan selesai :



Semoga bermanfaat untuk pembaca semua.

Dony Ramansyah
site : http://donyramansyah.net
blog : dony-ramansyah.blogspot.com
email : dony.ramansyah[at]gmail.com
Registered linux user : ID 40017

Senin, 08 Maret 2021

Cara Mount NFS di Solaris 10

 



Jadi kebutuhan saya saat ini adalah menambah disk di server SUN Solaris 10, karena saya belum bisa untuk menambahkan disk nya secara langsung dari SAN ke server Solaris 10, cara gampang nya adalah saya menyiapkan terlebih dahulu disk NAS dengan NFS lalu saya mount di server Solaris 10.

Cara untuk mount NFS di Solaris 10 adalah :

1. Buat dulu folder target dari mount point nya :

# mkdir /diskbaru

2. Jalankan perintah mount nya :

# mount -F nfs [-o mount-options] server:/directory /mount-point

atau :

# mount -F nfs 192.168.0.1:/vol/vol_disk_new/vol_disk_new_qtree /diskbaru


Semoga bermanfaat untuk pembaca semua.
Dony Ramansyah
site : http://donyramansyah.net
blog : dony-ramansyah.blogspot.com
email : dony.ramansyah[at]gmail.com
Registered linux user : ID 40017


Senin, 22 Februari 2021

Cara disable IPv6 di Ubuntu 20.04 LTS Focal Fossa

 


Wah sudah hampir akhir februari 2021 saja ini.. Semoga semua target kita bisa tercapai ya.. Kali ini saya akan sedikit share bagaimana cara untuk disable IPv6 di Ubuntu 20.04 LTS, Caranya adalah :

1. Pertama kali disable IPv6 dari sysctl, jalankan peritah dibawah ini :

$ sudo su
# sysctl -w net.ipv6.conf.all.disable_ipv6=1
net.ipv6.conf.all.disable_ipv6 = 1
# sysctl -w net.ipv6.conf.default.disable_ipv6=1
net.ipv6.conf.default.disable_ipv6 = 1
# sysctl -p

2. Edit dari grub nya juga, edit file /etc/default/grub :

$ sudo pico /etc/default/grub

Rubah dari baris seperti ini :
GRUB_CMDLINE_LINUX_DEFAULT=""

Menjadi :
GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1"

3. Update grub nya dengan perintah :

$ sudo update-grub


Semoga bermanfaat untuk pembaca semua.

Dony Ramansyah
site : http://donyramansyah.net
blog : dony-ramansyah.blogspot.com
email : dony.ramansyah[at]gmail.com
Registered linux user : ID 40017

Kamis, 04 Februari 2021

Mengatasi Problem PBM error occurred during PreCloneCheckCallback: Connection refused di VMware

 

Kali ini saya ingin sedikit share troubleshoot problem di VMware, problem nya adalah saya tidak bisa clone vm saya dan muncul error seperti ini :

"A general system error occurred: PBM error occurred during PreCloneCheckCallback: Connection refused"

Cara memperbaikinya seperti ini :

1. Login via ssh ke vcenter nya, lalu cek status service sps nya :

localhost:~ # service-control --status vmware-sps
INFO:root:Service: vmware-sps, Action: status
Service: vmware-sps, Action: status
2021-01-19T04:28:48.301Z   Running command: ['/sbin/service', u'vmware-sps', 'status']
2021-01-19T04:28:48.398Z   Done running command
INFO:root:Stopped:
 vmware-sps (VMware vSphere Profile-Driven Storage Service)
Stopped:
 vmware-sps (VMware vSphere Profile-Driven Storage Service)

2. Ternyata service sps nya down, kita tinggal hidupkan saja service nya :

localhost:~ # service-control --start vmware-sps

Lalu cek lagi :

localhost:~ # service-control --status vmware-sps
INFO:root:Service: vmware-sps, Action: status
Service: vmware-sps, Action: status
2021-01-19T04:29:06.554Z   Running command: ['/sbin/service', u'vmware-sps', 'status']
2021-01-19T04:29:06.699Z   Done running command
INFO:root:Running:
 vmware-sps (VMware vSphere Profile-Driven Storage Service)
Running:
 vmware-sps (VMware vSphere Profile-Driven Storage Service)
 
 
Semoga bermanfaat untuk pembaca semua.

Dony Ramansyah
site : http://donyramansyah.net
blog : dony-ramansyah.blogspot.com
email : dony.ramansyah[at]gmail.com
Registered linux user : ID 40017

Kamis, 21 Januari 2021

Cara Install PgAdmin dan Postgresql di Linux Centos 8

 


Melanjutkan instalasi server Centos kemarin, dimana ada cara instalasi baru di Linux Centos 8, yaitu dengan menggunakan "dnf". Kali ini saya akan sedikit share cara install PgAdmin dan Postgresql di Linux Centos 8.

Cara nya adalah :

1. Disable modul postgresql :

# dnf -qy module disable postgresql

Failed to set locale, defaulting to C.UTF-8

2. Download dan install PgAdmin dengan dnf :

# dnf install https://download.postgresql.org/pub/repos/yum/reporpms/EL-8-x86_64/pgdg-redhat-repo-latest.noarch.rpm

Failed to set locale, defaulting to C.UTF-8
Last metadata expiration check: 1:02:16 ago on Mon Jan 18 23:04:16 2021.
pgdg-redhat-repo-latest.noarch.rpm                                                                                    2.9 kB/s |  11 kB     00:03    
Dependencies resolved.
======================================================================================================================================================
 Package                                  Architecture                   Version                           Repository                            Size
======================================================================================================================================================
Installing:
 pgdg-redhat-repo                         noarch                         42.0-14                           @commandline                          11 k

Transaction Summary
======================================================================================================================================================
Install  1 Package

Total size: 11 k
Installed size: 11 k
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                              1/1 
  Installing       : pgdg-redhat-repo-42.0-14.noarch                                                                                              1/1 
  Verifying        : pgdg-redhat-repo-42.0-14.noarch                                                                                              1/1 
Installed products updated.

Installed:
  pgdg-redhat-repo-42.0-14.noarch                                                                                                                     

Complete!

3. Install postgresql dengan dnf dari repository :

# dnf install postgresql12 postgresql12-server

Failed to set locale, defaulting to C.UTF-8
Last metadata expiration check: 0:00:31 ago on Tue Jan 19 00:07:12 2021.
Dependencies resolved.
======================================================================================================================================================
 Package                                    Architecture                  Version                                 Repository                     Size
======================================================================================================================================================
Installing:
 postgresql12                               x86_64                        12.5-1PGDG.rhel8                        pgdg12                        1.7 M
 postgresql12-server                        x86_64                        12.5-1PGDG.rhel8                        pgdg12                        5.2 M
Installing dependencies:
 postgresql12-libs                          x86_64                        12.5-1PGDG.rhel8                        pgdg12                        396 k

Transaction Summary
======================================================================================================================================================
Install  3 Packages

Total download size: 7.3 M
Installed size: 31 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): postgresql12-libs-12.5-1PGDG.rhel8.x86_64.rpm                                                                  201 kB/s | 396 kB     00:01    
(2/3): postgresql12-12.5-1PGDG.rhel8.x86_64.rpm                                                                       492 kB/s | 1.7 MB     00:03    
(3/3): postgresql12-server-12.5-1PGDG.rhel8.x86_64.rpm                                                                780 kB/s | 5.2 MB     00:06    
------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                 1.1 MB/s | 7.3 MB     00:06     
warning: /var/cache/dnf/pgdg12-64e2194e85277659/packages/postgresql12-12.5-1PGDG.rhel8.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 442df0f8: NOKEY
PostgreSQL 12 for RHEL/CentOS 8 - x86_64                                                                              1.6 MB/s | 1.7 kB     00:00    
Importing GPG key 0x442DF0F8:
 Userid     : "PostgreSQL RPM Building Project <pgsqlrpms-hackers@pgfoundry.org>"
 Fingerprint: 68C9 E2B9 1A37 D136 FE74 D176 1F16 D2E1 442D F0F8
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-PGDG
Is this ok [y/N]: y
Key imported successfully
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                              1/1 
  Installing       : postgresql12-libs-12.5-1PGDG.rhel8.x86_64                                                                                    1/3 
  Running scriptlet: postgresql12-libs-12.5-1PGDG.rhel8.x86_64                                                                                    1/3 
  Installing       : postgresql12-12.5-1PGDG.rhel8.x86_64                                                                                         2/3 
  Running scriptlet: postgresql12-12.5-1PGDG.rhel8.x86_64                                                                                         2/3 
  Running scriptlet: postgresql12-server-12.5-1PGDG.rhel8.x86_64                                                                                  3/3 
  Installing       : postgresql12-server-12.5-1PGDG.rhel8.x86_64                                                                                  3/3 
  Running scriptlet: postgresql12-server-12.5-1PGDG.rhel8.x86_64                                                                                  3/3 
  Verifying        : postgresql12-12.5-1PGDG.rhel8.x86_64                                                                                         1/3 
  Verifying        : postgresql12-libs-12.5-1PGDG.rhel8.x86_64                                                                                    2/3 
  Verifying        : postgresql12-server-12.5-1PGDG.rhel8.x86_64                                                                                  3/3 
Installed products updated.

Installed:
  postgresql12-12.5-1PGDG.rhel8.x86_64         postgresql12-libs-12.5-1PGDG.rhel8.x86_64         postgresql12-server-12.5-1PGDG.rhel8.x86_64        

Complete!


Semoga bermanfaat untuk pembaca semua.

Dony Ramansyah
site : http://donyramansyah.net
blog : dony-ramansyah.blogspot.com
email : dony.ramansyah[at]gmail.com
Registered linux user : ID 40017

Rabu, 20 Januari 2021

Cara Install Apache dan PHP di Linux Centos 8

 


Ini pengalaman saya pertama kali Install Server dengan Linux Centos 8, saya melakukan instalasi nya dalam mode server tanpa GUI. Untuk pengalamannya tidak berbeda jauh dengan Centos 7, ada sedikit perbedaan dalam cara instalasi paket software nya saja.

Kali ini saya akan coba install Apache dan PHP di Linux Centos 8 menggunakan yum :

[root@localhost ~]# yum install httpd php

Failed to set locale, defaulting to C.UTF-8
Last metadata expiration check: 1:00:06 ago on Mon Jan 18 23:04:16 2021.
Dependencies resolved.
======================================================================================================================================================
 Package                             Architecture            Version                                                 Repository                  Size
======================================================================================================================================================
Installing:
 httpd                               x86_64                  2.4.37-30.module_el8.3.0+561+97fdbbcc                   appstream                  1.7 M
 php                                 x86_64                  7.2.24-1.module_el8.2.0+313+b04d0a66                    appstream                  1.5 M
Installing dependencies:
 apr                                 x86_64                  1.6.3-11.el8                                            appstream                  125 k
 apr-util                            x86_64                  1.6.1-6.el8                                             appstream                  105 k
 centos-logos-httpd                  noarch                  80.5-2.el8                                              baseos                      24 k
 httpd-filesystem                    noarch                  2.4.37-30.module_el8.3.0+561+97fdbbcc                   appstream                   37 k
 httpd-tools                         x86_64                  2.4.37-30.module_el8.3.0+561+97fdbbcc                   appstream                  104 k
 mod_http2                           x86_64                  1.15.7-2.module_el8.3.0+477+498bb568                    appstream                  154 k
 nginx-filesystem                    noarch                  1:1.14.1-9.module_el8.0.0+184+e34fea82                  appstream                   24 k
 php-cli                             x86_64                  7.2.24-1.module_el8.2.0+313+b04d0a66                    appstream                  3.1 M
 php-common                          x86_64                  7.2.24-1.module_el8.2.0+313+b04d0a66                    appstream                  661 k
Installing weak dependencies:
 apr-util-bdb                        x86_64                  1.6.1-6.el8                                             appstream                   25 k
 apr-util-openssl                    x86_64                  1.6.1-6.el8                                             appstream                   27 k
 php-fpm                             x86_64                  7.2.24-1.module_el8.2.0+313+b04d0a66                    appstream                  1.6 M
Enabling module streams:
 httpd                                                       2.4                                                                                     
 nginx                                                       1.14                                                                                    
 php                                                         7.2                                                                                     

Transaction Summary
======================================================================================================================================================
Install  14 Packages

Total download size: 9.2 M
Installed size: 31 M
Is this ok [y/N]: y
Downloading Packages:
(1/14): apr-util-1.6.1-6.el8.x86_64.rpm                                                                               1.4 MB/s | 105 kB     00:00    
(2/14): apr-1.6.3-11.el8.x86_64.rpm                                                                                   1.6 MB/s | 125 kB     00:00    
(3/14): apr-util-bdb-1.6.1-6.el8.x86_64.rpm                                                                           304 kB/s |  25 kB     00:00    
(4/14): apr-util-openssl-1.6.1-6.el8.x86_64.rpm                                                                       500 kB/s |  27 kB     00:00    
(5/14): httpd-filesystem-2.4.37-30.module_el8.3.0+561+97fdbbcc.noarch.rpm                                             270 kB/s |  37 kB     00:00    
(6/14): httpd-tools-2.4.37-30.module_el8.3.0+561+97fdbbcc.x86_64.rpm                                                  1.1 MB/s | 104 kB     00:00    
(7/14): nginx-filesystem-1.14.1-9.module_el8.0.0+184+e34fea82.noarch.rpm                                              694 kB/s |  24 kB     00:00    
(8/14): mod_http2-1.15.7-2.module_el8.3.0+477+498bb568.x86_64.rpm                                                     3.3 MB/s | 154 kB     00:00    
(9/14): httpd-2.4.37-30.module_el8.3.0+561+97fdbbcc.x86_64.rpm                                                        3.7 MB/s | 1.7 MB     00:00    
(10/14): php-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64.rpm                                                          4.1 MB/s | 1.5 MB     00:00    
(11/14): php-common-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64.rpm                                                   4.5 MB/s | 661 kB     00:00    
(12/14): centos-logos-httpd-80.5-2.el8.noarch.rpm                                                                     1.3 MB/s |  24 kB     00:00    
(13/14): php-cli-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64.rpm                                                      4.6 MB/s | 3.1 MB     00:00    
(14/14): php-fpm-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64.rpm                                                      4.4 MB/s | 1.6 MB     00:00    
------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                 4.6 MB/s | 9.2 MB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                              1/1 
  Installing       : php-common-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                                                                      1/14 
  Running scriptlet: httpd-filesystem-2.4.37-30.module_el8.3.0+561+97fdbbcc.noarch                                                               2/14 
  Installing       : httpd-filesystem-2.4.37-30.module_el8.3.0+561+97fdbbcc.noarch                                                               2/14 
  Installing       : apr-1.6.3-11.el8.x86_64                                                                                                     3/14 
  Running scriptlet: apr-1.6.3-11.el8.x86_64                                                                                                     3/14 
  Installing       : apr-util-bdb-1.6.1-6.el8.x86_64                                                                                             4/14 
  Installing       : apr-util-openssl-1.6.1-6.el8.x86_64                                                                                         5/14 
  Installing       : apr-util-1.6.1-6.el8.x86_64                                                                                                 6/14 
  Running scriptlet: apr-util-1.6.1-6.el8.x86_64                                                                                                 6/14 
  Installing       : httpd-tools-2.4.37-30.module_el8.3.0+561+97fdbbcc.x86_64                                                                    7/14 
  Installing       : php-cli-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                                                                         8/14 
  Installing       : centos-logos-httpd-80.5-2.el8.noarch                                                                                        9/14 
  Installing       : mod_http2-1.15.7-2.module_el8.3.0+477+498bb568.x86_64                                                                      10/14 
  Installing       : httpd-2.4.37-30.module_el8.3.0+561+97fdbbcc.x86_64                                                                         11/14 
  Running scriptlet: httpd-2.4.37-30.module_el8.3.0+561+97fdbbcc.x86_64                                                                         11/14 
  Running scriptlet: nginx-filesystem-1:1.14.1-9.module_el8.0.0+184+e34fea82.noarch                                                             12/14 
  Installing       : nginx-filesystem-1:1.14.1-9.module_el8.0.0+184+e34fea82.noarch                                                             12/14 
  Installing       : php-fpm-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                                                                        13/14 
  Running scriptlet: php-fpm-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                                                                        13/14 
  Installing       : php-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                                                                            14/14 
  Running scriptlet: httpd-2.4.37-30.module_el8.3.0+561+97fdbbcc.x86_64                                                                         14/14 
  Running scriptlet: php-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                                                                            14/14 
  Running scriptlet: php-fpm-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                                                                        14/14 
  Verifying        : apr-1.6.3-11.el8.x86_64                                                                                                     1/14 
  Verifying        : apr-util-1.6.1-6.el8.x86_64                                                                                                 2/14 
  Verifying        : apr-util-bdb-1.6.1-6.el8.x86_64                                                                                             3/14 
  Verifying        : apr-util-openssl-1.6.1-6.el8.x86_64                                                                                         4/14 
  Verifying        : httpd-2.4.37-30.module_el8.3.0+561+97fdbbcc.x86_64                                                                          5/14 
  Verifying        : httpd-filesystem-2.4.37-30.module_el8.3.0+561+97fdbbcc.noarch                                                               6/14 
  Verifying        : httpd-tools-2.4.37-30.module_el8.3.0+561+97fdbbcc.x86_64                                                                    7/14 
  Verifying        : mod_http2-1.15.7-2.module_el8.3.0+477+498bb568.x86_64                                                                       8/14 
  Verifying        : nginx-filesystem-1:1.14.1-9.module_el8.0.0+184+e34fea82.noarch                                                              9/14 
  Verifying        : php-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                                                                            10/14 
  Verifying        : php-cli-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                                                                        11/14 
  Verifying        : php-common-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                                                                     12/14 
  Verifying        : php-fpm-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                                                                        13/14 
  Verifying        : centos-logos-httpd-80.5-2.el8.noarch                                                                                       14/14 
Installed products updated.

Installed:
  apr-1.6.3-11.el8.x86_64                                                   apr-util-1.6.1-6.el8.x86_64                                               
  apr-util-bdb-1.6.1-6.el8.x86_64                                           apr-util-openssl-1.6.1-6.el8.x86_64                                       
  centos-logos-httpd-80.5-2.el8.noarch                                      httpd-2.4.37-30.module_el8.3.0+561+97fdbbcc.x86_64                        
  httpd-filesystem-2.4.37-30.module_el8.3.0+561+97fdbbcc.noarch             httpd-tools-2.4.37-30.module_el8.3.0+561+97fdbbcc.x86_64                  
  mod_http2-1.15.7-2.module_el8.3.0+477+498bb568.x86_64                     nginx-filesystem-1:1.14.1-9.module_el8.0.0+184+e34fea82.noarch            
  php-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                           php-cli-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                       
  php-common-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                    php-fpm-7.2.24-1.module_el8.2.0+313+b04d0a66.x86_64                       

Complete!

Semoga bermanfaat untuk pembaca semua.

Dony Ramansyah
site : http://donyramansyah.net
blog : dony-ramansyah.blogspot.com
email : dony.ramansyah[at]gmail.com
Registered linux user : ID 40017

Selasa, 12 Januari 2021

Mengatasi Problem "open raw socket permission denied" pada nmap di Ubuntu 20.04 LTS

 


Saya coba melakukan instalasi nmap dari snap, begitu dijalan kan muncul error "Couldn't open a raw socket. Error: Permission denied (13)"

Sepertinya program nmap yang saya install dari snap belum di permit ke network, dan berikut solusi nya jalankan berikut berikut :

$ snap connect nmap:network-control


Semoga bermanfaat untuk pembaca semua.

Dony Ramansyah
site : http://donyramansyah.net
blog : dony-ramansyah.blogspot.com
email : dony.ramansyah[at]gmail.com
Registered linux user : ID 40017

Senin, 11 Januari 2021

Cara Mengganti Hostname di Linux Ubuntu 20.04 LTS

 


Tutorial kali ini hanya ingin sedikit sharing cara untuk mengganti hostname di Linux Ubuntu 20.04 LTS, Cara nya adalah sebagai berikut :

1. Cek dulu nama hostname existing :

$ hostnamectl

2. Ganti nama hosting lama dengan nama hostname baru :

$ sudo hostnamectl set-hostname newNameHere

3. Kemudian cek kembali hasil perubahannya 

$ hostnamectl


Namun untuk merubah hostname secara permanent, kita bisa ikuti langkah berikut :

1. Edit file hosts :

$ sudo nano /etc/hosts

2. Edit isi nya dari nama hostname existing menjadi nama hostname baru yang di inginkan, lalu simpan perubahan file nya

3. Kemudian restart linux nya :

$ sudo reboot

Semoga bermanfaat untuk pembaca semua.

Dony Ramansyah
site : http://donyramansyah.net
blog : dony-ramansyah.blogspot.com
email : dony.ramansyah[at]gmail.com
Registered linux user : ID 40017